Neon America
October 30, 2020, 04:16:44 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: New Technical Service Manuals,
These are the same manuals your dealer and the professional Technicians use for Maintenance, repairs and service work.  For more information on this please check out the following post.
 http://www.neonamerica.org/forum/index.php?topic=809.0
 
    Home   Help Login Register  
Pages: [1]
  Send this topic  |  Print  
Author Topic: speedo  (Read 743 times)
kevin
Online Member
*
Posts: 4


Email
« on: January 24, 2007, 03:37:29 PM »

when im driving down the road sumtimes my speedometor doesnt work and my fuel gaauge doesnt work what cud the problem be?
Logged
Garrett Brown
Online Member
*
Posts: 4

TouchThePainter
Email
« Reply #1 on: January 25, 2007, 06:23:19 AM »

i get that same problem too, with my speedometer and my tachometer. have you had any engine work done to your car? it might have been jarred loose.
Logged
kevin
Online Member
*
Posts: 4


Email
« Reply #2 on: January 25, 2007, 07:12:51 PM »

no engine work that ik of has been done.....ive been reading mayb ill check and see if it needs to be solderd..
Logged
Northern
Administrator
Online Member
*****
Posts: 2



Email
« Reply #3 on: January 26, 2007, 08:30:07 AM »

Clean the connections for the cluster.
Logged
Harry Bushling
Global Moderator
Just can't stay away
*****
Posts: 632

212220969 neonhondakiller@hotmail.com neonhondakiller neonhondakiller
WWW Email
« Reply #4 on: February 02, 2007, 07:46:50 PM »

it needs to be fixed.look in back post about the problem thank you
Logged

HARRY BUSHLING
A.K.A. NEONHONDAKILLER
V.P.NEONAMERICA CAR CLUB VP@NEONAMERICA.COM
PRES.SOCAL NEON AMERICA CAR CLUB SOCAL@SOCALNEONAMERICA.COM
Pages: [1]
  Send this topic  |  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.12 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!